JQL extension for invalid component version does not match with the setting Applicable Versions in Multi-Component Issues: 'Union'

Description

Update add-on configuration “Applicable Versions in Multi-Component Issues” to “Union”:


If Issue have 1 component; (In this case, no problem)
If Issue have 2 components; (The problem is here)

  • Case 1: One is a versioned component, and the other one is a component without a version;
    Even if the appropriate version is chosen for versioned component, issue is displayed in issuesWithInvalidVersion JQL (incorrect) and there is no red label on the issue view (correct).

  • Case 2: Both versioned component;
    Even if the version is suitable for either of the two, issue is displayed with issuesWithInvalidVersion JQL (incorrect) and there is no red label on the issue view (correct)

For both of above cases, expected behavior is: issue should not be displayed with issuesWithInvalidVersion and it should not be highlighted as invalid version on the issue view.

Environment

None
Your pinned fields
Click on the next to a field label to start pinning.

Assignee

Deniz Oğuz

Reporter

Gökçe Karaduman